Apache2 stops when OpenSSH runs

April 7, 2016 508 views

I'm a newbie.

I've manage to setup and run Ubuntu 14.04 server with LAMP on a laptop and run it for more than a year.

My problem now is that I updated to versions Ubuntu 14.04.1, Apache 2.4.7, MySQL 5.5.47 and OpenSSH 6.6.1.
I now have the problem that Apache can't start when OpenSSH runs. If I stop OpenSSH then Apache starts but then I cant work from my Win 7 running Bitvise SSH Client.

I understand it's a port sharing problem on port 22 with apache and OpenSSH server. It worked before and the problem came after i upd. I've google but can't find a solution I understand.

The error message I get when I start apache and OpenSSh is running:

sudo service apache2 start

  • Starting web server apache2 AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message (98)Address already in use: AH00072: makesock: could not bind to address [::]:22 (98)Address already in use: AH00072: makesock: could not bind to address no listening sockets available, shutting down AH00015: Unable to open logs Action 'start' failed. The Apache error log may have more information. *
  • The apache2 instance did not start within 20 seconds. Please read the log files to discover problems

Can anyone help me solve this apache/OpenSSH problem?


  • You've configured Apache2 to operate on port 22 for some reason. It doesn't do that by default. You need to change the configuration to use other ports (I suggest normal ports: 80/443.)

  • I have no idea!

    I haven't done any thing out of what the "How To Set Up Apache Virtual Hosts on Ubuntu 14.04 LTS" tutorial I found here on digitalocean told me to do.

    Everything worked until I upd versions.

    I've change it and now it works again.


Be the first one to answer this question.