This question has been archived.

DNS resolver no longer working after kernel upgrade

August 30, 2014 1.9k views

I just updated my kernel to 3.13.0-33-generic ubuntu 14.04 via the control panel. After the upgrade I am getting "Waiting for network to start.." during the boot process and then "Waiting and additional 60 seconds for network to start..". Eventually the droplet starts but I seem to be having issues.

I think that this issue is related to the resolvconf script that is used by default.

If I run..

resolvconf -d eth0 works just fine. As soon as I run..

resolvconf -a eth0 add it back into the parsing for DNS servers the script hangs and won't complete. I believe that is what could be causing the 'Waiting for network..' at boot time. Anybody see this before?

1 comment
  • Apparently 'resolvconf' is not working properly because networking is unable to start properly after kernel upgrade. The issue with adding 'eth0' using the above command is a different issue.

Be the first one to answer this question.