Droplet resolves to ns1.digitalocean.com which will not work wint mail-in-a-box how to fix?

May 30, 2015 1k views
Configuration Management DigitalOcean Articles System Tools DNS Ubuntu

I have been following the DO tutorial on installing mail-in-a-box.

mail-in-a-box tutorial

I have no opportunity to actually goto the mail-in-a-box install step until my droplet resolves using the prescribed DNS.

Currently the droplet resolves using DO DNS (ns1.digitalocean.com).

Below I'm using the men and mice online dig application.

dig @ns1.digitalocean.com datamaskinaggie.xyz

; <<>> DiG 9.8.1-P1 <<>> @ns1.digitalocean.com datamaskinaggie.xyz SOA +norecurse +m
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28003
;; flags: qr aa; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
;datamaskinaggie.xyz.   IN SOA
datamaskinaggie.xyz.    1800    IN  SOA ns1.digitalocean.com. hostmaster.datamaskinaggie.xyz. ( 
1432938508 ; serial
10800 ; refresh (3 hours)
3600 ; retry (1 hour)
604800 ; expire (1 week)
1800 ; minimum (30 minutes)
;; Query time: 34 msec
;; SERVER: 2400:cb00:2049:1::adf5:3a33#53(2400:cb00:2049:1::adf5:3a33)
;; WHEN: Sat May 30 13:51:55 2015
;; MSG SIZE rcvd: 104

The tutorial expressly points to using this template: ns1.box.example.com and ns2.box.example.com

The statement above will never happen until I correct /etc/hostname.

Using the DO prescribed step:

sudo echo "box.example.com" > /etc/hostname

returns permission denied though I am logged in as root.

I have been working this issue for about a week.

What to do?

Be the first one to answer this question.