FileZilla: "Permision Denied" when I try to rename folder remotely

October 28, 2015 957 views
WordPress PHP Security Ubuntu

Hi all!

I am having troubles on my wordpress website and it seems like the problem originates from one of the plugins I updated just recently. So, to fix this I tried changing the plugin folder's name through SFTP using FileZilla but it always gives me this error:

Command: mv "jquery-post-splitter" "jquery-post-splitter.disabled"
Error: mv /var/www/html/wp-content/plugins/jquery-post-splitter /var/www/html/wp-content/plugins/jquery-post-splitter.disabled: permission denied

and to be honest I've been getting permission denied ALL THE TIME whenever I want to change something on my site remotely using SFTP.

I also tried changing stuff around using SSH with no success. DigitalOcean support told me to ask a developer but I think the problem is not so big of a problem to shed in some bucks. If anyone have any suggestion, it would be super!!

I have a feeling I do not have the permission to actually touch my remote site. I am wondering how can I give myself permission to access my own site remotely through SFTP? Otherwise I suppose the problem could easily be fixed through FileZilla.

  • Hi,

    Which user are you attempting to make these changes with? Does your user have sudo capabilities?

  • Hello! Thank you for replying. Yes, my user have sudo capabilities. I applied it when I created my droplet.

  • I just tried sftp (the command) on my droplet, and I don't see a way to change the user. That is, you log in as "", you remain "user". So I think this is a permission problem related to the user and the permission of the directory in question. I doubt filezilla can get around the user issue.

    Use caution when doing a chown or chmod to fix the problem.

Be the first one to answer this question.