Fresh Install of OpenVPN Access Server Connection Refused

Posted March 19, 2016 10k views

I have a fresh install of Debian Lamp server, everything works perfectly (Web server, mysql etc). Note: Before I proceed with OpenVPN installation I took a snapshot of my server.

Then I wget the package of OpenVPN and then dpkg -i as their instructions advised.

The first time I installed it I was able to login to the admin panel and do stuff. But i tried to change the hostname in the OpenVPN settings (instead of my IP I set my domain ( since then I have no access on the Openvpn. I tried to telnet myip 943 and it response with connection refused. I even restored back to the snapshot and proceed with the same steps of installation of OpenVPN and no luck. I dont understand, why this is happening. Even with restoring the server from the snapshot prior the installation did not solve the problem. Any suggestions?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Hey there,

You may want to make sure that OpenVPN AS is not binding to the Anchor IP that we use for floating IP’s (The Anchor IP will start with a 10 and can be seen when ran ’ip addr show’).

ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 04:01:be:f0:cb:01 brd ff:ff:ff:ff:ff:ff
    inet 111.222.333.444/18 brd 111.222.333.1 scope global eth0
       valid_lft forever preferred_lft forever
    inet brd scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::601:f01/64 scope link 
       valid_lft forever preferred_lft forever

You may want to try to run the following command and choose (1) to bind to all interfaces:

  • /usr/local/openvpn_as/bin/ovpn-init

Happy coding,

Jon Schwenn
Platform Support Specialist

  • Hello, I had the same problem and did as you suggested - to bind to all interfaces. Now the connection is no longer refused, but times out (it says “connecting…”). What can I do now?