Ghost Admin - Blank Page because of Javascript errors

March 28, 2015 896 views

I have a droplet here (Linux PhakeApps 3.13.0-36-generic #63-Ubuntu SMP Wed Sep 3 21:30:07 UTC 2014 64 x8664 x86_64 GNU/Linux).

I installed ghost on a subdomain (I'm using nginx). I succeeded the first time, It was running for two three weeks and suddenly I wasn't able to log in into the Admin panel. It was just a blank page. I saw in the developers console that the javascript files have some errors. That's why the page wasnt rendered. I tried everything I found as solutions in Google, but nothing worked for me.

So I decided to make a fresh installation. Several times. Every time the error occures again. I tried installing it by downloading a copy of Ghost, I tried installing it by cloning the repository from Github. Nothing worked.

The blog actually is working, but the admin area is somehow "broken". You can find the blog on http://blog.phakeapps.com/ and the admin area: http://blog.phakeapps.com/ghost/setup/

If you open the dev console, you can see the errors.

  • The link to the admin page redirects to the signin page for users not logged in. At least that page doesn't have any errors. Could you pastebin what you're seeing? Additionally, checking the Nginx error logs in /var/log/nginx/error.log might show something useful.

  • I did all of those stuff you mentioned, but this didnt help. Either the logs were empty or irrelevant. I ended up setting a new droplet that is dedicated to ghost. :) Thanks anyways.

Be the first one to answer this question.