How to get Tomcat7 working on Docker?

September 6, 2015 1.8k views
Java Docker Deployment Apache One-Click Install Apps Ubuntu

Hi guys, I am running a Docker pre-installed Droplet. I tried for days to deploy with Tomcat7 without success. I just pulled tomcat:7-jre7 following both the image and Docker docs. Then I run it with -p 8888:8080 and mounted all my stuff. Now, Tomcat simply doesn't run the deployed apps (even the default ones) the only thing I can get (from the browser) is:"waiting for [my-droplet]". It actually doesn't work. Am I missing some hidden config? Even did the DO's getting started with Docker, and Googled.
I hope that someone can help me, thanks.
Cheers

2 comments
  • I am facing similiar problem. I build tomcat image and run it -p 80:8080 as docker attach tomcat seem to run normally. However, when I tried to access http://[Public IP]/ the browser just waiting. I believe there must be a routing issue but I can't figure out how to fix it. Hope someone know the answer.

  • Hi, did you get some clue after your reply? :)

Be the first one to answer this question.