I reinstalled Apache in my WordPress install without backing it up and now my site is not working


I was enabling http/2 and I for some stupid reason reinstalled Apache without backing up it’s files.

I spent a lot of time now trying to recreate the Apache files that were automatically generated when I created this WordPress install via 1 click install, to no avail.

I am trying to figure out how to get the files I need to get this Droplet working again.

  • Right now I’ve got apache up and running, I’ve enabled AllowOverride All in apache.conf:
  • I also ran a2ensite as well
  • I added ServerName to the 000-default.conf in sites-available fire

I also downloaded apache files from other droplets that are working and tried to re-create the same feel, no luck. Apache is not showing anything in error logs

Could you please point me where should I look and what should i do to T/S this since my site is still not loading?

Thank you


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Thank you @jarland and @X40C for contribution!

What ended up being and issue is next error message:

Considering conflict mpm_event for mpm_prefork:
ERROR: Module mpm_event is enabled - cannot proceed due to conflicts. It needs to be disabled first!

Leaving that just in case someone else has the same/similar issue :)

Go to and check both and and verify if they both have the same ip address(your droplet’s ip address).

Hey friend,

Sounds like you’ve been busy and making a solid effort on this. Maybe I can help you look at it differently. At this point I think let’s break away from trying to make the configs match their original, and focus on the current state of it. What is currently happening that causes this to not work? Describe to me where the live result breaks from the desired result, and what that looks like from your perspective. Error messages, etc.

Focusing on the current state and moving forward from there will probably put us on the right path.



How about taking the backup of WordPress content and database through terminal (assuming the files still exists)?

Then you can migrate the whole site to the new droplet.


Hi @jarland thanks again!!

I just noticed this daily message when I SSH in: *** System restart required *** I’m not sure what’s this referring to but I restarted apache multiple times.

More importantly, when i do curl -I, it shows: curl: (7) Failed to connect to port 443: Connection refused

My previous setup was with let’s encrypt installed, and domain was set with www. If I try and run curl -I i get response HTTP/1.1 200 OK and when I go there it shows this text:

 * Front to the WordPress application. This file doesn't do anything, but loads
 * wp-blog-header.php which does and tells WordPress to load the theme.
 * @package WordPress

 * Tells WordPress to load the WordPress theme and output it.
 * @var bool
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
require( dirname( __FILE__ ) . '/wp-blog-header.php' );

I’m not sure if port 80 is closed but i ran the iptables -I INPUT -p tcp --dport 80 -j ACCEPT and it didn’t return anything and nothing changed on the site after that.

I reinstalled Let’s Encrypt just in case, but nothing changed. Do you maybe have a reccomendation based on the above?

Thank you SO MUCH for the time and I hopefully your graphic card drivers are going to behave from now on :)

Thank you !