iptables (and ufw) wont start

May 17, 2015 642 views
Firewall Security Ubuntu

Maybe you could help me out. iptables doesn't work for my droplet.

sudo iptables -F
FATAL: Could not load /lib/modules/3.16.0-37-generic/modules.dep: No such file or directory
iptables v1.4.12: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
uname -r

My droplet's current kernel is set to Ubuntu 14.10 x64 vmlinuz-3.16.0-37-generic.

I've tried

sudo apt-get install linux-image-$(uname -r)

But I get

E: Unable to locate package linux-image-3.16.0-37-generic
E: Couldn't find any package by regex 'linux-image-3.16.0-37-generic'

I'm not sure what to do anymore. I'm no expert with linux, but I'm under the impression that when I upgraded the kernel, some files under /lib/modules/ where not added. Does it has anything to do with the DigitalOcean's packages?

I also tried uninstalling/purging iptables and ufw to no avail.

Any hints welcome.

1 comment
Be the first one to answer this question.