Issue installing Corosync for HA using DigitalOcean HowTo

April 1, 2016 443 views
Load Balancing High Availability Ubuntu

I have been working on setting up a demo HA environment on DigitalOcean. I have been using their how-to guide and have almost finished. I get the the part below:

Configure Cluster Properties

Now we're ready to configure the basic properties of Pacemaker. Note that all Pacemaker (crm) commands can be run from either node server, as it automatically synchronizes all cluster-related changes across all member nodes.

For our desired setup, we want to disable STONITH—a mode that many clusters use to remove faulty nodes—because we are setting up a two-node cluster. To do so, run this command on either server:

sudo crm configure property stonith-enabled=false
We also want to disable quorum-related messages in the logs:

sudo crm configure property no-quorum-policy=ignore
Again, this setting only applies to 2-node clusters.

If you want to verify your Pacemaker configuration, run this command:

sudo crm configure show
This will display all of your active Pacemaker settings. Currently, this will only include two nodes, and the STONITH and quorum properties you just set.

When I try to run the crm commands - "crm configure property stonith-enabled=false" I see the following errors:

crm configure property stonith-enabled=false

ERROR: CIB not supported: validator 'pacemaker-2.0', release '3.0.9'
ERROR: You may try the upgrade command

Everything is up-to-date. Anyone else run into this issue and discover a workaround?

Thanks for the help!

Be the first one to answer this question.