Move droplet with VestaCP to anoter region with snapshot. Vesta CP configuration?

I tried to move a droplet (not in production) with Ubuntu + Vesta control panel to another region. I made a snapshot, moved to the other region and created the new droplet from the image.

All went almost well. The only problem is that I can not connect through http (port 80). I can connect to VestaCP port 8083, FTP … all seems fine but port 80. Digging I’ve found that nginx was not running. Lurking through the logs I see that it is trying to start the local ip address of the previous droplet. The configuration of Vesta is still having the old IPs so I guess it’s a matter of erasing and creating the new ones.

I will recreate the droplet but before I’d like to ask if anyone knows specific steps to follow to re-configure the IPs and anything else when the droplet is using VestaCP. (from what I’ve seen in the instructions to move apparently you don’t need to do anything with Apache, Nginx etc, right?)

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Problem solved: I had to remove the old IPs in Vesta and add the ones of the new droplet.

But first look in Vesta -> Web. If there’s any domain assigned to the old local IP, you must change this or you will not be able to delete that old local IP.