My website does not load the first time, needs a refresh.

August 8, 2016 549 views
WordPress DigitalOcean

Website does not load the first time when I click on the page links, It loads only when I refresh the url. And sometimes when I click one page, it goes to another one. It's happening last one month and I tried everything to solve this problem. Because of this, in google page titles are not showing properly. Website is in wordpress and this is not a problem with my wordpress theme because the same thing happening in all the themes I installed. And I tried with uninstalling all plugins. issue happens more systematically when people try to reach the website using Firefox.

  • You need to give some more information before we can help you;

    • What kind of droplet are you using with which webserver etc. ?
    • What does your VHOST config look like?
    • Post your DNS settings
    • When you refresh, is the url still the same as you entered the first time?
  • @CrypticDesigns

    • Ubuntu 14.04.4 x64 with apache2 .

    • VHost Config :

    <VirtualHost *:80>

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
    <Directory /var/www/html/>
    AllowOverride All
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
    CacheQuickHandler off
    CacheLock on
    CacheLockPath /tmp/mod_cache-lock
    CacheLockMaxAge 5
    CacheIgnoreHeaders Set-Cookie
    <Location />
        CacheEnable disk
        CacheHeader on
        CacheDefaultExpire 600
        CacheMaxExpire 86400
        CacheLastModifiedFactor 0.5
        ExpiresActive on
        ExpiresDefault "access plus 5 minutes"
        Header merge Cache-Control public
        FileETag All
    <files xmlrpc.php>
    order allow,deny
    deny from all


    • And for DNS, I am using cloudflare settings

    • When I refresh it goes to the correct page of that url.

    Thank you

  • Are you still seeing this happen if you access your site directly via the IP address instead of by domain and via CloudFlare?

Be the first one to answer this question.