MySQL Workbench Connection

October 15, 2014 4.7k views

I have already come very far from bluehost to digitalocean configuration, but im struggling with mysql workbench login from my pc.
In bluehost i could just whitelist my current home IP and then login with mysql workbench, when i set .cnf to: . and try to connect in mysql workbench over standard (tcp/ip) im presented with password promt (in sudo password works) which i enter and then get error: Access denied for user ‘root’@'’(using password:YES).
any idea what im doing wrong?

  • Just to be clear, it should be the password MySql root user, not the login password. Is that what you’re using?

  • yes, thats why on Putty and sudo mysql it’s working. but not in workbench…:(

2 Answers

seems to work now, i had to use something like that too:

guess need to read into user management of mysql more.
an handy manual would be helpful for that, there are some but not as easy as for others subjects.

Have you checked your bind setting in the my.cnf, it should be binded to the outbound IP address of your droplet.

Have another answer? Share your knowledge.