New to Gnome 3 - Startx problems with qxl_surface_create problem

January 10, 2017 581 views
DigitalOcean VPN Ubuntu 16.04

Been following a lot of guides and can't seem to fix a problem i am having running Gnome 3 (i am fairly new to it).

I installed it without any errors but when i run startx from putty i get the following error. i also tried increasing the RAM but not sure if i need to increase it further (its at 2gb atm) or whether it is something else.

X.Org X Server 1.18.4
Release Date: 2016-07-19
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.4.0-45-generic x8664 Ubuntu
Current Operating System: Linux laravel 4.4.0-57-generic #78-Ubuntu SMP Fri Dec 9 23:50:32 UTC 2016 x86
64
Kernel command line: BOOTIMAGE=/boot/vmlinuz-4.4.0-57-generic root=UUID=a132a837-d929-4b7a-b3e3-832e9178294a ro console=tty1 console=ttyS0
Build Date: 02 November 2016 10:06:10PM
xorg-server 2:1.18.4-0ubuntu0.2 (For technical support please see http://www.ubuntu.com/support)
Current version of pixman: 0.33.6
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jan 10 09:56:09 2017
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) [KMS] drm report modesetting isn't supported.
resizing surface0 to 16777216
memory space from 0x7f4703023000 to 0x7f4706020000
memory space from 0x7f4701023000 to 0x7f4702023000
resizing surface0 to 16777216
memory space from 0x7f4703848000 to 0x7f4706845000
memory space from 0x7f4701848000 to 0x7f4702848000
slots start: 1, slots end: 7
done reset
qxl
surfacecreate: Bad bpp: 1 (1)
qxl
surfacecreate: Bad bpp: 1 (1)
qxl
surfacecreate: Bad bpp: 1 (1)
qxl
surface_create: Bad bpp: 1 (1)

3 comments
  • Can you provide some clarification on the environment you are setting up? Are you attempting to run Gnome 3 headless, via VNC or x2go or in some other way?

    Putty can be configured to do X forwarding in it's configuration but you must have a local X server installed to display the windows. I am not sure if the full Gnome 3 environment will run via X forwarding in this fashion.

  • i was trying to run it headless using RealVNC. Everything else is the default Digital Ocean Droplet with Ubuntu 16.0.4 installed.
    I was mainly using this document to set it up: https://www.digitalocean.com/community/questions/how-to-install-ubuntu-desktop-and-vnc

  • I personally have never managed to get Gnome 3 to work with VNC or x2go. It's known to be unsupported by x2go. I would recommend for remote access using a different desktop environment such as MATE (based on Gnome 2.x), XFCE, etc.

Be the first one to answer this question.