Nginx 502 Bad Gateway error after installing tomcat 8

September 4, 2015 1.4k views
Nginx CentOS

I am getting bad gateway error After installing tomcat8. I dont know what may be the problem to check problem I used nginx -t this is not shoing any error I have 3 config file which I have posted here

I run

nginx -t

nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

For more information on configuration, see:

* Official English Documentation: http://nginx.org/en/docs/

* Official Russian Documentation: http://nginx.org/ru/docs/

user nginx;
workerprocesses auto;
log /var/log/nginx/error.log;
pid /run/nginx.pid;

events {
worker_connections 1024;

http {
logformat main '$remoteaddr - $remoteuser [$timelocal] "$request" '
'$status $bodybytessent "$httpreferer" '
useragent" "$httpxforwardedfor"';

access_log  /var/log/nginx/access.log  main;

sendfile            on;
tcp_nopush          on;
tcp_nodelay         on;
keepalive_timeout   65;
types_hash_max_size 2048;

include             /etc/nginx/mime.types;
default_type        application/octet-stream;

# Load modular configuration files from the /etc/nginx/conf.d directory.
# See http://nginx.org/en/docs/ngx_core_module.html#include
# for more information.
include /etc/nginx/conf.d/*.conf;
 server {
    listen       80 default_server;
     listen       [::]:80 default_server;
     server_name  _;
     root         /usr/share/nginx/html;

     # Load configuration files for the default server block.
     include /etc/nginx/default.d/*.conf;

     location / {
 ## Add the following lines ##

location ~ \.php$ {
          root           /usr/share/nginx/html;
          try_files $uri =404;
          fastcgi_split_path_info ^(.+\.php)(/.+)$;
          fastcgi_index  index.php;
          fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
          include        fastcgi_params;

    error_page 404 /404.html;
        location = /40x.html {

    error_page 500 502 503 504 /50x.html;
        location = /50x.html {

conf.d/tomcat.conf cat tomcat.conf

server {
listen 80;

# proxy_cache one;

location / {
setheader Host $host;
setheader X-Real-IP $remoteaddr;
proxysetheader X-Forwarded-For $proxyaddxforwardedfor;
proxysetheader X-Forwarded-Proto $scheme;
proxysetheader X-Forwarded-Host $host;

cat php-fpm.conf

PHP-FPM FastCGI server

network or unix domain socket configuration

upstream php-fpm {
server unix:/run/php-fpm/www.sock;
What may be the problemand how can I resolve this?

Be the first one to answer this question.