Doskias
By:
Doskias

No multiple nginx server blocks (vhosts)

January 20, 2016 1.4k views
Nginx PHP Ubuntu

Hello DigitalOcean Community,

I have the following:

  • 1 Ubuntu 14.04 VPS setup here at DigitalOcean.

  • Nginx installed from official ubuntu repos (no 3rd party PPA)

  • HHVM installed and configured to run through a socket:

    fastcgi_pass   unix:/var/run/hhvm/hhvm.sock;
    

For the sake of simplicity I will refer to the ip address of the server as "serv_ip"

I have setup a vhost config for my project. Let's call it "doproj". I have populated the config file under /etc/nginx/sites-available/doproj

Below is my configuration under the /etc/nginx/sites-available/doproj :

server {
    charset utf-8;
    client_max_body_size 128M;

    listen 80; ## listen for ipv4
    #listen [::]:80 default_server ipv6only=on; ## listen for ipv6

    server_name doproj;
    root        /var/www/html/doproj/frontend/web;
    index       index.php;

    access_log  /var/www/html/doproj/log/access.log;
    error_log   /var/www/html/doproj/log/error.log;

    location / {
        # Redirect everything that isn't a real file to index.php
        try_files $uri $uri/ /index.php?$args;
    }

    # uncomment to avoid processing of calls to non-existing static files by Yii
    #location ~ \.(js|css|png|jpg|gif|swf|ico|pdf|mov|fla|zip|rar)$ {
    #    try_files $uri =404;
    #}
    #error_page 404 /404.html;

    location ~ \.php$ {
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root/$fastcgi_script_name;
        fastcgi_pass   unix:/var/run/hhvm/hhvm.sock;
        try_files $uri =404;
    }

    location ~ /\.(ht|svn|git) {
        deny all;
    }
}

Note: I am using Yii 2 Framework. This is why I have to put the root as /var/www/html/doproj/frontend/web

Also, my default config (/etc/nginx/sites-available/default) is:

# You may add here your
# server {
#   ...
# }
# statements for each of your virtual hosts to this file
##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##
server {
    listen 80 default_server;
    #listen [::]:80 default_server ipv6only=on;
    #root /usr/share/nginx/html;
    root /var/www/html;
    index index.html index.htm index.php;
    # Make site accessible from http://localhost/
    server_name localhost;
    include hhvm.conf;
    location / {
        # First attempt to serve request as file, then
        # as directory, then fall back to displaying a 404.
        try_files $uri $uri/ =404;
        # Uncomment to enable naxsi on this location
        # include /etc/nginx/naxsi.rules
    }
    location ~ \.(hh|php)$ {
            fastcgi_keep_conn on;
            fastcgi_pass   unix:/var/run/hhvm/hhvm.sock;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;
            include        fastcgi_params;
        }
    # Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests
    #location /RequestDenied {
    #   proxy_pass http://127.0.0.1:8080;    
    #}
    #error_page 404 /404.html;
    # redirect server error pages to the static page /50x.html
    #
    #error_page 500 502 503 504 /50x.html;
    #location = /50x.html {
    #   root /usr/share/nginx/html;
    #}
    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
    #
    #location ~ \.php$ {
    #   fastcgi_split_path_info ^(.+\.php)(/.+)$;
    #   # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
    #
    #   # With php5-cgi alone:
    #   fastcgi_pass 127.0.0.1:9000;
    #   # With php5-fpm:
    #   fastcgi_pass unix:/var/run/php5-fpm.sock;
    #   fastcgi_index index.php;
    #   include fastcgi_params;
    #}
    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #   deny all;
    #}
}
# another virtual host using mix of IP-, name-, and port-based configuration
#
#server {
#   listen 8000;
#   listen somename:8080;
#   server_name somename alias another.alias;
#   root html;
#   index index.html index.htm;
#
#   location / {
#       try_files $uri $uri/ =404;
#   }
#}
# HTTPS server
#
#server {
#   listen 443;
#   server_name localhost;
#
#   root html;
#   index index.html index.htm;
#
#   ssl on;
#   ssl_certificate cert.pem;
#   ssl_certificate_key cert.key;
#
#   ssl_session_timeout 5m;
#
#   ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
#   ssl_ciphers "HIGH:!aNULL:!MD5 or HIGH:!aNULL:!MD5:!3DES";
#   ssl_prefer_server_ciphers on;
#
#   location / {
#       try_files $uri $uri/ =404;
#   }
#}

My nginx user is "www-data". The root folder is owned by www-data recursively and has 755 unix permissions. The "doproj" config file has a link created in /etc/nginx/sites-enabled along the default config.

When I access the vps through the browser with http://serv_ip it displays the nginx default page which is ok. However, if I try to access http://serv_ip/doproj to get to the vhost it displays a very beautiful "403 Forbidden" error message.

I don't want to buy a domain, I just want to make things accessible via the http://serv_ip/doproj address. I have tried the following in order to fix this issue:

  • Took ownership recursively of /var/www/html as user and group www-data
  • Gave 755 permissions recursively on /var/www/html which includes my doproj folder.

The above did not fix the issue so I did the following:

  • Changed nginx user to root. Restarted nginx as root.
  • Gave 777 permissions recursively on /var/www/html

The above did not fix my issue. I am still not able to access my vhost via http://serv_ip/doproj

If I remove the default config file then I am able to access the doproj directly through the http://serv_ip however I don't want this. HHVM works as I've tested it with a phpinfo file. The package installed is nginx-extras as this contains the full nginx setup.

I have reverted the user to www-data and changed back the permissions to 755 (recursively).

Is there something I can do to make this stupid nginx work like I want or should I switch to apache? I just want to access my "doproj" using a simple http://serv_ip/doproj address in the browser.

Any help is appreciated. This thing is driving me crazy.

1 comment
Be the first one to answer this question.