Not able to increase Open File limit(ulimit -n)

August 22, 2014 2.2k views

Hello,

I want to increase Open file limit of my server to 300000 but i am not able to update it.
I have applied below changes-

ulimit -n 300000

echo "fs.file-max= 300000" >> /etc/sysctl.conf

echo "* soft nofile 300000" >> /etc/security/limits.conf

echo "* hard nofile 300000" >> /etc/security/limits.conf

echo "session required pam_limits.so" >> " /etc/pam.d/common-session"

Reboot the server but still no success it's set as default.

ulimit -n

1024

Thanks

2 comments
  • I just met the same problem, do you have any solution right now ?

  • I have the same problem on two droplets, I cannot raise the values.

    One thing I noticed in the systemd-logind.log there are errors like:
    /proc/self/fd/9: 4: ulimit: error setting limit (Invalid argument)

    Process with pid=9 seems to be "rcuos".

    Anyone else got this?

Be the first one to answer this question.