bluenote
By:
bluenote

Piwik 2.8.3 and php 5.3.3 not recognized

November 10, 2014 866 views

I started to install the last piwik (2.8.3) behind a domain on my droplet but got problem to finish it. I have this in red ' Erreur: Version PHP > 5.3.3 requis' and so, i can't keep on install this version.

So, looks like piwik doesn't see the version of php required is installed.

Does anybody else saw this bug?
Any idea?

1 Answer

Hi,

I looks like this was caused by a bug in the Piwik version check code. It was just fixed six days ago and will be in the next Piwik release. To work around the problem temporarily, edit the file piwik/core/testMinimumPhpVersion.php and change

$piwik_minimumPHPVersion = '5.3.3';

to

$piwik_minimumPHPVersion = '5.3.2';

h/t to decken-it.com

Have another answer? Share your knowledge.