Postfix issues - SPAM on Gmail

May 11, 2016 494 views
Email LAMP Stack Getting Started PHP

I'm having some issues when sending email with postfix.

1 - It's always flagged as a SPAM when I send to my gmail account.
2 - On the details I'm getting www-data@mydomain.com

Delivered-To: xxxxxx@gmail.com
Received: by 10.194.242.228 with SMTP id wt4csp427855wjc;
Wed, 11 May 2016 11:25:58 -0700 (PDT)
X-Received: by 10.55.145.6 with SMTP id t6mr5317079qkd.206.1462991158417;
Wed, 11 May 2016 11:25:58 -0700 (PDT)
Return-Path: www-data@mydomin.com
Received: from smt ([104.236.239.40])
by mx.google.com with ESMTP id l4si6037003qhl.74.2016.05.11.11.25.57
for xxxxxxx@gmail.com;
Wed, 11 May 2016 11:25:58 -0700 (PDT)
Received-SPF: temperror (google.com: error in processing during lookup of www-data@sysmediatracking.com: DNS error) client-ip=xxx.xxx.xxx.xx;
Authentication-Results: mx.google.com;
spf=temperror (google.com: error in processing during lookup of www-data@mydomain.com: DNS error) smtp.mailfrom=www-data@mydomain.com
Received: by smt (Postfix, from userid 33)
id 805EB142660; Wed, 11 May 2016 14:25:57 -0400 (EDT)
To: xxxxx@gmail.com
Subject: TEST
X-PHP-Originating-Script: 1000:Login.php
MIME-Version: 1.0
Content-type: text/html; charset=utf-8
From: noreply@mydomain.com
Message-Id: 20160511182557.805EB142660@smt
Date: Wed, 11 May 2016 14:25:57 -0400 (EDT)

1 comment
  • Hi @leandrommaia,

    Is mydomain the domain you're trying to send from, or did you update the paste to hide the domain? That said, there're a number of reasons that this could be happening. If you could provide us with a little more information on the to/from domains. Also, have you setup the SPF/DNS records accordingly?

Be the first one to answer this question.