Problem with add expire days for bucket from s3cmd

Posted October 9, 2017 3.7k views
Block Storage

I try add expire days from file and bucket but have this problem:

sudo s3cmd expire s3://<my-bucket>/ --expiry-days=3 expiry-prefix=backup

ERROR: Error parsing xml: syntax error: line 1, column 0
ERROR: not found
ERROR: S3 error: 404 (Not Found)

and this

sudo s3cmd expire s3://<my-bucket>/<folder>/<file> --expiry-day=3

ERROR: Parameter problem: Expecting S3 URI with just the bucket name set instead of ‘s3://<my-bucket>/<folder>/<file>’

How add expire days in DO Spaces for folder or file from s3cmd?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

Hi dorlenko,

I’ve come across this issue too this evening. Did you ever find a fix or workaround?

I’ve just submitted a support request with DO support, so hoping to hear back about whether this is something DO Spaces supports, whether it’s in the product backlog or failing that, where we can submit a feature request.

If I find out anything useful, I’ll post it back here, but was wondering whether you got any further than me.



  • Hello!
    I don’t found how fix this problem with s3cmd tool.
    I solved this problem using a script. Which keeps track of the number of copies and removes the oldest.

Hi @dorlenko

Thanks for coming back to me. I’ve decided to take the same route. I’ve put up a Github Gist:

I wonder how this compares to your solution.

Anyone else reading this, please feel free to try this script out and remember to test it in a safe environment thoroughly as deletions are destructive!

Hope this helps.



Hi @barryfisher

I solved this problem differently.
Later I’ll write about your script.