Question

Rstudio and shiny server connection problems (127.0.0.1 refused to connect)

I have set up Rstudio and shiny servers. Both seemed to be working OK (the demo apps work and I can log into & use Rstudio from a browser). But now I have two (possibly related?) problems:

  1. In Rstudio, I get this error “127.0.0.1 refused to connect” whenever I try to run a Shiny app or even try to open a help page. (e.g. ?runApp, or ?mean).

  2. I copied an existing shiny app to /srv/shiny-server/. It worked fine at first, but after I made some changes (on a local version of R) and replaced the files on the server, I get this error when trying to launch the app:

An error has occurred The application failed to start. The application exited during initialization.

Warning in readLines(file, warn = FALSE) : cannot open file ‘/srv/shiny-server/SMP_shinyapp/global.R’: Permission denied Error in readLines(file, warn = FALSE) : cannot open the connection Calls: runApp -> <Anonymous> -> sourceUTF8 -> readUTF8 -> readLines Execution halted

I am very new to using servers, ubuntu etc. I got as far as I did by following tutorials and googling stuff, but now I am completely stuck. Any advice would be greatly appreciated!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Please check your credentials properly. Also, if it is ok then check your directory permissions and assign you as an owner so that you can change your directory but make sure that no other users can change your directory, only you can change your directories.

Once I came across this situation while using Shiny and RStudio. When you are working with servers, it is always a permissions issue.

Any luck with this? I am experiencing the same problem.

Explain that answer, please. I have the same problem as the original question poser. I have two apps which are running on my shiny-server just fine and one which seems to have exactly the same permissions as these first two but generates an error when I try to run it (as per the error referenced by the original questioner). It seems to be something to do with the app itself.