Run the UNIX 'say' command on a droplet

Posted March 5, 2015 3.5k views
Linux BasicsMiscellaneousNode.jsSystem Tools

I know it sounds silly, but I’d like to run the ‘say’ command from my droplet — you can save the output by adding ’-o filename.aiff’, and I’d like to use those files for my app. It’s simpler than using a text-to-speech API from elsewhere, and I like the stock voices.

Understandably, my droplet doesn’t have the correct drivers. I get the following error:

ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
audio_open_alsa: failed to open audio device default. No such file or directory

I tried installing the ALSA drivers and libraries, but it still doesn’t work. I’ve exhausted my own knowledge here — does anyone have any advice?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

This is great! I’ll give it a shot now, thanks so much.

Hrm this is proving to be fairly tricky — have you ever done this successfully on a droplet yourself?