Question

SSL certificate failed PLS HELP

Posted December 21, 2020 1.3k views
Nginx

As I was trying to add a SSL certificate by running sudo certbot --nginx. It failed to connect to the website. I was using a domain I got from a digital ocean app. I have created an A and AAAA record.
Here’s the image of the A/AAAA. PNG IMAGE

Here’s the error I receive while creating the certificate.

root@zombs:~# sudo certbot --nginx
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated)  (Enter 'c' to cancel): the-new-zombs-io-ploro.ondigitalocean.app
Requesting a certificate for the-new-zombs-io-ploro.ondigitalocean.app
Performing the following challenges:
http-01 challenge for the-new-zombs-io-ploro.ondigitalocean.app
Waiting for verification...
Challenge failed for domain the-new-zombs-io-ploro.ondigitalocean.app
http-01 challenge for the-new-zombs-io-ploro.ondigitalocean.app
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: the-new-zombs-io-ploro.ondigitalocean.app
   Type:   connection
   Detail: Fetching
   https://the-new-zombs-io-ploro.ondigitalocean.app/.well-known/acme-challenge/nwrC4yXiNrryD2LWmSdnFlGstL_UBLVhV76VOJVcZjk:
   Timeout after connect (your server may be slow or overloaded)

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address. Additionally, please check that
   your computer has a publicly routable IP address and that no
   firewalls are preventing the server from communicating with the
   client. If you're using the webroot plugin, you should also verify
   that you are serving files from the webroot path you provided.
root@zombs:~# sudo ufw disable
Firewall stopped and disabled on system startup
root@zombs:~# sudo certbot --nginx
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
No names were found in your configuration files. Please enter in your domain
name(s) (comma and/or space separated)  (Enter 'c' to cancel): the-new-zombs-io-ploro.ondigitalocean.app
Requesting a certificate for the-new-zombs-io-ploro.ondigitalocean.app
Performing the following challenges:
http-01 challenge for the-new-zombs-io-ploro.ondigitalocean.app
Waiting for verification...
Challenge failed for domain the-new-zombs-io-ploro.ondigitalocean.app
http-01 challenge for the-new-zombs-io-ploro.ondigitalocean.app
Cleaning up challenges
Some challenges have failed.

IMPORTANT NOTES:
 - The following errors were reported by the server:

   Domain: the-new-zombs-io-ploro.ondigitalocean.app
   Type:   unauthorized
   Detail: Invalid response from
   https://the-new-zombs-io-ploro.ondigitalocean.app/.well-known/acme-challenge/RMJMHL5OgZnOQ_0BQrWvsTcQleiPOTMaIh3YzvQO4sc
   [2606:4700::6810:f34e]: 503

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi there @jadeyongxinli,

There is actually already an SSL certificate for the-new-zombs-io-ploro.ondigitalocean.app. It is covered by the Wildcard SSL certificate for *.ondigitalocean.app.

Can you clarify why do you need another SSL certificate?

Also as a side note, I don’t think that this is would work as in order to use Let’s Encrypt you need to actually be the owner of the domain name, in this case, the *.ondigitalocean.app domain is managed by DigitalOcean and goes through Cloudflare, so Let’s Encrypt will not be able to verify that you own the domain.

Hope that this helps!
Regards,
Bobby

Thanks! I’ve decided to use freenom and everything works perfecly. Thanks for your reply.