Starting MySQL fails after upgrading to MySQL 5.6

June 21, 2016 279 views
MySQL Debian


While setting up a test server for the development of a Magento plugin, I ran into the requirement of MySQL 5.6. I was already using MySQL 5.5 so running apt-get install mysql-server-5.6 should have done the trick. Upon finishing the installation, this happened:

[....] Starting MySQL database server: mysqldNo directory, logging in with HOME=/
[FAIL. . . . . . . . . . . . . . . . . . . . . . . . . . . . failed!
invoke-rc.d: initscript mysql, action "start" failed.
dpkg: error processing package mysql-server-5.6 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-server-5.6; however:
  Package mysql-server-5.6 is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-22) ...
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

The MySQL server won't start anymore. I've tried service mysql start but the same thing happens. Any suggestions? I'm running Debian 7.

Thanks in advance,
Roemer Bakker

1 comment
  • You could try to reconfigure the mysql package, as the message indicates, to see if it helps

    dpkg-reconfigure mysql-server


    dpkg-reconfigure mysql-server-5.6
Be the first one to answer this question.