[statscheck] Stats/Server Overload

November 12, 2014 1k views

Hi all,

I've been receiving these emails since yesterday (received every 6 hours or so) titled
[statscheck] Stats/Server Overload on vps.xxxxxx.com
Basically saying that one of my account is running a very high CPU usage.
And when I checked the "top" command, I found that indeed one account is running about 50-90% CPU usage constantly.
I found that this happen only since the last 2 days.
Not sure whether it's the source of problem but from what I remember I only installed wp-mail-smtp plugin on that account's website.
I've already deactivated the plugin with no result, the CPU is still running high.

Can anyone suggest where should I start finding the main source of this problem?
Just FYI I'm running CentOS 6.4 and using WHM/Cpanel.
And here's some lines from the top command

top - 13:20:39 up 43 days, 12:58,  1 user,  load average: 1.89, 1.79, 2.08
Tasks: 129 total,   3 running, 124 sleeping,   1 stopped,   1 zombie
Cpu(s): 75.4%us, 24.6%sy,  0.0%ni,  0.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   1030628k total,   977808k used,    52820k free,   186932k buffers
Swap:        0k total,        0k used,        0k free,   255264k cached

13840 user001  20   0 40056 9504 4840 R 84.7  0.9   1647:12 php

Thanks in advance for any info.

1 comment
  • I got some valuable additional info, thanks to Michael from Cpanel support team.
    The high CPU usage is coming from this script:
    /usr/bin/php /home/user001/public_html/wp-content/themes/index.php

    He ran a strace command using "strace -vvfp 13840", which results in it flooding the screen with the following output:
    access("/home/", ROK) = -1 EACCES (Permission denied)
    access("/home/", R
    OK) = -1 EACCES (Permission denied)
    access("/home/", ROK) = -1 EACCES (Permission denied)
    access("/home/", R
    OK) = -1 EACCES (Permission denied)

    The script seems to be trying to access /home with permissions it does not have, and I am not sure why it would need to access /home at all.
    That's as far as he can help to troubleshoot this.
    Anyone can please advise me where should I go from here?

Be the first one to answer this question.