Suddenly all websites under one droplet cannot access databases

Posted October 24, 2017 1.5k views
MySQLApachePHPLAMP StackUbuntu 16.04

This morning every website I had under one droplet (this is a dev server) cannot access databases. All are throwing 500 errors. Websites with no databases work fine. Yesterday, they were all working fine. I even tried websites I haven’t touched recently and they weren’t working too. Seems to be a droplet problem? Sorry if this doesn’t make sense. Anyone run into this issue? I already contacted support but I thought I’d also check here.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Just rebooted and it fixed it. Super annoying though and I still don’t know why it happened....

I’m not sure this is actually fixed, although I too can get things running again (at least, temporarily) by rebooting.

I had the same issue, and then after playing around with it awhile, I came across this recent bug report:

This is only affecting my droplets running Ubuntu 16.04. I can get everything running again by rebooting, but I can’t actually upgrade the software—installation hangs, or I’ll get locked out.

Hopefully they can fix this soon.