Trying to install wordpress via ajenti

October 7, 2015 1.6k views
Nginx WordPress

Hi I have followed the guide on setting up Ajenti - created a website - and after a refresh I get the following error

nginx: [emerg] no port in upstream "None" in /etc/nginx/conf.d/********.conf:61 nginx: configuration file /etc/nginx/nginx.conf test failed

I have created a new droplet and gone through the instructions 4 times now

Step 1 https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-14-04

Step 2 https://www.digitalocean.com/community/tutorials/how-to-install-the-ajenti-control-panel-and-ajenti-v-on-ubuntu-14-04

Step 3 https://www.digitalocean.com/community/tutorials/installing-wordpress-on-ajenti-v

The file content

AUTOMATICALLY GENERATED - DO NO EDIT!

server {
listen *:80;

ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
server_name ***.co.uk;

access_log /var/log/nginx/***.access.log;
error_log /var/log/nginx/****.error.log;

root /srv/nomadmike;
index index.html index.htm index.php;

# This order might seem weird - this is attempted to match last if rules below fail.

location / {
try_files $uri $uri/ /index.php?$args;
}

Add trailing slash to */wp-admin requests.

rewrite /wp-admin$ $scheme://$host$uri/ permanent;

Directives to send expires headers and turn off 404 error logging.

location ~* ^.+.(ogg|ogv|svg|svgz|eot|otf|woff|mp4|ttf|rss|atom|jpg|jpeg|gif|png|ico|zip|tgz|gz|rar|bz2|doc|xls|exe|ppt|tar|mid|midi|wav|bmp|rtf)$ {
accesslog off; lognot_found off; expires max;
}

location = /favicon.ico {
lognotfound off;
accesslog off;
}
location = /robots.txt {
allow all;
log
notfound off;
access
log off;
}

Deny all attempts to access hidden files such as .htaccess, .htpasswd, .DS_Store (Mac).

Deny access to any files with a .php extension in the uploads directory

Works in sub-directory installs and also in multisite network

Keep logging the requests to parse later (or to pass to firewall utilities such as fail2ban)

location ~* /(?:uploads|files)/.*.php$ {
deny all;
}

location  / {

    try_files $uri =404;

fastcgisplitpath_info ^(.+.php)(/.+)$;

    include fcgi.conf;
    fastcgi_pass None;

}

}

1 comment
  • Can you post the content from /etc/nginx/conf.d/********.conf ?

    When you post it, can you use code blocks (you can surround the text with ``` on either side)

Be the first one to answer this question.