Ubuntu 12.04.5 x64 show only blank page

September 18, 2014 1.3k views

I'm now setupped my website 5-7 times, with different locations
I'm tried intall prosper202 click server (i'm already installed one to my account and it work well)

Now i used same tutorial to install but when i open my "website" it show blank page
When i go with IP it show welcome to ngingx

1 comment
1 Answer

Yup i think that too but where is mistake?

There is tutorial what i'm used

1) sudo apt-get purge apache2* bind9* samba*
2) sudo apt-get update
3) sudo apt-get upgrade
4) sudo apt-get install python-software-properties
5) sudo add-apt-repository ppa:ondrej/php5
6) sudo apt-get update
7) sudo apt-get install php5-common php5-mysql php5-xmlrpc php5-cgi php5-curl php5-gd php5-cli php5-fpm php-pear php5-dev php5-imap php5-mcrypt
8) sudo apt-get install mysql-server mysqltuner
9) sudo add-apt-repository ppa:nginx/stable
10) sudo apt-get update
11) sudo apt-get install nginx
12) sudo reboot - After this command you'll be logged off the putty. You'll need to restart it and log in your with root and your password again.
13) sudo apt-get install zip
14) sudo mkdir -p /var/www/yourdomain.com/htdocs/ /var/www/yourdomain.com/logs/
15) cd /var/www/yourdomain.com/
16) sudo wget http://prosper.tracking202.com/apps/download/latest/prosper202.zip
17) sudo unzip prosper202.zip
18) sudo mv /var/www/yourdomain.com/prosper202/* /var/www/yourdomain.com/ - IGNORE THIS STEP WITH PROSPER 1.8.X versions
19) sudo rm prosper202.zip
20) sudo chown -R www-data:www-data /var/www/yourdomain.com/
21) mysql -u root -p
22) grant all privileges on . to dbuser@localhost identified by "dbpass"; - Here replace "dbuser" with the desired username for your database and "dbpass" with the desired password for your database.
23) create database dbname; - Replace "dbname" with the desired name for your database
24) quit - just type in the word "quit" :) no quitting here, you're almost done.
25) sudo nano /etc/nginx/sites-available/yourdomain.com - Then paste the following info, change yourdomain.com to your actual domain.

server {
       listen   80;

        server_name yourdomain.com www.yourdomain.com;

   access_log   /var/log/nginx/yourdomain.com;
   error_log    /var/log/nginx/yourdomain.com;

        root /var/www/yourdomain.com/;
        index index.php;

        location / {
                try_files $uri $uri/ /index.php?$args;

        location ~ \.php$ {
                include fastcgi_params;
                fastcgi_pass unix:/var/run/php5-fpm.sock;

       if ($query_string ~ "\b(BoxOfAd|boxofad)\b") {
               rewrite ^(.*)$ http://google.com redirect;

PRESS CTRL + X, type Y and press ENTER.

26) sudo ln -s /etc/nginx/sites-available/yourdomain.com /etc/nginx/sites-enabled/yourdomain.com
27) sudo service nginx reload - if it shows you [failed] message, do the steps 29,30 first and then continue to the step 28.
28) sudo nano /etc/php5/fpm/php.ini - Find the line "shortopentag = Off" and change it to "shortopentag = On" . Delete ; or # from the beginning of the line if there is any.

Find the line "date.timezone =" and change it to "date.timezone = US/Pacific" or any time zone. Just google php time zones. Delete ; or # from the beginning of the line if there is any.

PRESS CTRL + X, type Y and press ENTER.

29) sudo nano /etc/nginx/nginx.conf - Find the line which says "servernameshashbucketsize 64; " and remove # before this line.
30) sudo reboot

I'm replaced every yourdomain.com with my own

EDIT; would problem be domain provider? i'm used 1and1 before but now i moved to godaddy

  • EDIT; would problem be domain provider? i'm used 1and1 before but now i moved to godaddy

    I doubt that. As long as your nameservers are properly configured, it doesn't matter who your registrar is.

    Do you see any errors in nginx's error log?

    sudo tail -30 /var/log/nginx/error.log
Have another answer? Share your knowledge.