Unable to login to registry via `doctl registry login` - docker-credential-doctl executable not found

Posted March 26, 2021 873 views
DockerDigitalOcean API and CLI (doctl)DigitalOcean Container Registry (DOCR)

I am using doctl version 1.57.0:

> doctl version

doctl version 1.57.0-release
Git commit hash: 497c900

I installed doctl using the GitHub download method for Linux (Ubuntu 20.04).

When I run the command to log in to the registry I get the following error:

> doctl registry login

Logging Docker in to
Error: error storing credentials - err: exec: "docker-credential-doctl": executable file not found in $PATH, out: ``

I have also tried installing via snap and I get the exact same problem.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer


Can you use doctl for any other purpose like getting information about your account ?

doctl account get

Does it work or you get another error message ?

  • I can use doctl for pretty much everything else, including creating droplets etc.

    > doctl account get                   
    Email                      Droplet Limit    Email Verified    UUID                                        Status
    <email>                    50               true              <uid>    active
    • I observed that invoking doctl registry login makes modifications in at least two places:

      1. File ~/.docker/config.json
      There is auth token written there. File’s content looks like:

          "auths": {
              "": {

      2. In DO account, it creates access token that is visible in DO Control Panel, under Account-API section. The list of access tokens looks like:

      Name Scope Created
      container-registry-your-registry-name-timestamp read 12 minutes ago
      container-registry-your-registry-name-timestamp read/write 28 minutes ago
      container-registry-your-registry-name-timestamp read/write 31 minutes ago
      personal-access-token read/write six months ago

      It may be an issue with creating tokens in your account.

      Anyway, I would open a new ticket to get the DO support.