chrisjob
By:
chrisjob

Unmet dependencies problems

February 18, 2015 1.7k views

I have a ubuntu 14.4 droplet. I tried install the following software QGIS, and now get the following messages (see below):

I've tried every suggestion I could find to clear up this issue but no luck. Any suggestions as to how I can resolve this issue would be appreciated

Chris

The following packages have unmet dependencies:
grass-core : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
Recommends: gdal-bin but it is not going to be installed
libopenscenegraph99 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
libosgearth2 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
libosgearthfeatures2 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
libqgis-analysis2.6.1 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
libqgis-core2.6.1 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
libqgis2.2.0 : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
python-qgis-common : Depends: gdal-bin but it is not going to be installed
Depends: python-gdal but it is not going to be installed
qgis : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
qgis-plugin-grass : Depends: libgdal1h (>= 1.8.0) but it is not going to be installed
qgis-providers : Depends: libgdal1h (>= 1.9.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

2 comments
  • Are you attempting an install via apt-get or using dpkg to install a deb package directly?

    Have you run the recommended apt-get -f install as the message recommends? If so, can you share the output of that command?

  • I'm using apt-get to install the application

    Here is the result of the apt-get -f install

    ~# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
    gdal-bin libgdal1h python-gdal
    The following NEW packages will be installed:
    gdal-bin libgdal1h python-gdal
    0 upgraded, 3 newly installed, 0 to remove and 175 not upgraded.
    Need to get 5,026 kB of archives.
    After this operation, 18.6 MB of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Get:1 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main libgdal1h amd64 1.11.1+dfsg-1~exp2~trusty [4,105 kB]
    Get:2 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main gdal-bin amd64 1.11.1+dfsg-1~exp2~trusty [370 kB]
    Get:3 http://ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu/ trusty/main python-gdal amd64 1.11.1+dfsg-1~exp2~trusty [551 kB]
    Fetched 5,026 kB in 2s (1,968 kB/s)
    (Reading database ... 146999 files and directories currently installed.)
    Preparing to unpack .../libgdal1h1.11.1+dfsg-1~exp2~trustyamd64.deb ...
    Unpacking libgdal1h (1.11.1+dfsg-1~exp2~trusty) ...
    dpkg: error processing archive /var/cache/apt/archives/libgdal1h1.11.1+dfsg-1~exp2~trustyamd64.deb (--unpack):
    trying to overwrite '/usr/lib/libgdal.so.1.18.1', which is also in package libgdal 1.11.1-1+opengeo
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Preparing to unpack .../gdal-bin1.11.1+dfsg-1~exp2~trustyamd64.deb ...
    Unpacking gdal-bin (1.11.1+dfsg-1~exp2~trusty) ...
    dpkg: error processing archive /var/cache/apt/archives/gdal-bin1.11.1+dfsg-1~exp2~trustyamd64.deb (--unpack):
    trying to overwrite '/usr/bin/gdalgrid', which is also in package libgdal 1.11.1-1+opengeo
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Preparing to unpack .../python-gdal
    1.11.1+dfsg-1~exp2~trustyamd64.deb ...
    Unpacking python-gdal (1.11.1+dfsg-1~exp2~trusty) ...
    dpkg: error processing archive /var/cache/apt/archives/python-gdal
    1.11.1+dfsg-1~exp2~trustyamd64.deb (--unpack):
    trying to overwrite '/usr/bin/epsg
    tr.py', which is also in package libgdal 1.11.1-1+opengeo
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
    Errors were encountered while processing:
    /var/cache/apt/archives/libgdal1h1.11.1+dfsg-1~exp2~trustyamd64.deb
    /var/cache/apt/archives/gdal-bin1.11.1+dfsg-1~exp2~trustyamd64.deb
    /var/cache/apt/archives/python-gdal1.11.1+dfsg-1~exp2~trustyamd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

Be the first one to answer this question.