Question

W3 total cache error

I have installed wordpress using this guide https://www.digitalocean.com/community/articles/how-to-install-wordpress-with-nginx-on-ubuntu-12-04

Now site working fine but I am facing errors when I try to install W3 total cache.


I get the following error:

FTP credentials don’t allow to write to file /var/www/nginx.conf

W3 Total Cache Error: Files and directories could not be automatically created to complete the installation.

Please execute commands manually

or use FTP form to allow W3 Total Cache make it automatically.


I have installed FTP using this guide

https://www.digitalocean.com/community/articles/how-to-set-up-vsftpd-on-ubuntu-12-04 thanks


Please help.I am confused

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Try using ‘easyengine’, it will automate the process of installing and configuring Nginx + PHP-FPM + MySQL + Postfix + WordPress + W3TC + many more options <br>https://rtcamp.com/easyengine/docs/commands/site/create/

.htaccess File Permission Error Due to the security plugins, other plugins lost their writing permission to .htaccess and other files. The solution is simple.

  1. Check the directory permission level is 755 (in case WordPress installed in the directory).
  2. Now check the file permission for .htaccess which is necessary to be 644. Otherwise, you will encounter the error.

Source: DoubtSolver

@ajinkyathete: Once you update it, make sure you change its ownership back to root: <pre>sudo chown root /var/www/nginx.conf</pre>.