tony1
By:
tony1

weird encoding issues in htop

April 14, 2015 1.2k views
Linux Basics Getting Started Debian

I just installed a stock Debian 7 image and from the looks of it, I can see that en_US.UTF-8 is the default language/character set.

My putty session is also set to UTF8 in "Translation" option menu. But when I run htop I see some weird characters as shown in this screenshot:

http://i.imgur.com/EHFn7gw.png

What are those [?] characters, Is there anyway to get rid of them?

2 comments
  • What's the output of locale -a ? Regenerating them might help, try: sudo dpkg-reconfigure locales

  • hey @asb
    locale -a outputs:

    C
    C.UTF-8
    en_US.utf8
    POSIX
    

    and doing sudo dpkg-reconfigure locales brings up a ncurses window to choose which locale I want to enable. en_US.utf8 is already selected. After choosing it as default locale, it prints out:

    Generating locales (this might take a while)...
        en_US.UTF-8... done
    Generation complete.
    

    Unfortunately, it does not fix those weird questions marks in htop.

Be the first one to answer this question.