Weird Permissions Issue? Files 404'ing

June 17, 2015 639 views
WordPress Linux Basics LEMP

Long story short, I inherited a WP site from someone. It was previously hosted elsewhere and as a favour took it on.

However ever since I have had weird permission(?) issues with various files and have come across another tonight.

A js file needed for Gravity Forms 404s - jquery.json-1.3.js

I have tried to change the permissions of the file but am unable to. From within the folder I run:

sudo find . -type f -print0 | xargs -0 chmod 0644
chmod: changing permissions of ‘./jquery.json-1.3.js’: Operation not permitted

The permissions look like this:

-rw-rw-rw- 1 www-data www-data 4884 Jun 17 21:04 jquery.json-1.3.js

I host probably 12 different WP sites across DO so do have some experience with WP and DO, and am a front end dev so feel I have covered the obvious issues. However I am tearing my hair out unable to solve this.

Any help would be appreciated!

1 comment
  • Oh other files in that directory are accessible if that is any help so I think it rules out folder permissions but I am not 100% ??

Be the first one to answer this question.