Why is my DNS resolution different depending on the tool I'm using?

Posted September 26, 2020 497 views


This is probably a dumb question, but why would nmap and dig resolve the IP address to my droplet correctly, but I am only able to connect to it using the IPv4 address? Maybe this is just a wait 48-hours thing, but I’m worried it might have something to do with me enabling IPv6 as this is the first time I’ve ever tried to use it.

ping -4
PING (IPV4_ADDRESS) 56(84) bytes of data.
64 bytes from IPV4_ADDRESS (IPV4_ADDRESS): icmp_seq=1 ttl=51 time=37.2 ms


ping -6
PING (IPV6_ADDRESS)) 56 data bytes...

So nothing seems to work with IPv6. I assume my browser is using IPV6 as well, since it fails to connect. I would just turn this back off, but I couldn’t find any way to do this. Any ideas?

PS: My assumption is that it’s just a crappy router or ISP config on my end, so no biggy on the lack of IPv6 support! I was just curious to see if it worked out of the box yet.

Cheers, and thanks for your time!

1 comment
  • Sorry I meant to change the title before I posted. My original question was a bit different until I figured out what the problem actually was. I couldn’t find a way to edit.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer