wordpress displaying blank page after move

February 9, 2015 1.3k views

I moved my website from shared hosting to digital ocean. I am using nginx. Other website is working fine.

I have just blank page here http://richmondgardens.ie/

Other website on same droplet. http://qbfweb.com/

this is my configuraion file

server {
listen 80;

    root /var/www/richmondgardens.ie;
    index index.php index.html index.htm;

    server_name www.richmondgardens.ie richmondgardens.ie;

    location / {
            # try_files $uri $uri/ =404;
            try_files $uri $uri/ /index.php?q=$uri&$args;

    error_page 404 /404.html;

    error_page 500 502 503 504 /50x.html;
    location = /50x.html {
            root /usr/share/nginx/html;

    location ~ \.php$ {
            try_files $uri =404;
            fastcgi_split_path_info ^(.+\.php)(/.+)$;
            fastcgi_pass unix:/var/run/php5-fpm.sock;
            fastcgi_index index.php;
            include fastcgi_params;


  • Hi! A blank page usually means that a PHP error has occurred. Are there any errors in nginx's error log?

    sudo tail /var/log/nginx/error.log
  • here is the log

    2015/02/09 07:46:13 [error] 14307#0: *349 directory index of "/var/www/" is forbidden, client:, server:, request: "GET http://www.google.com/ HTTP/1.0", host: "www.google.com"
    2015/02/09 08:07:58 [error] 14307#0: *350 directory index of "/var/www/" is forbidden, client:, server:, request: "GET / HTTP/1.1", host: ""

  • What permissions and ownership do you have on /var/www/richmondgardens.ie?

    If you are running on Ubuntu (the user is different for different distributions) you can ensure this directory and it's files are owned by the correct user by running:

    chown -Rf www-data:www-data /var/www/richmondgardens.ie
  • still the same. i run this command but the website is still blank. strange

  • anybody can help me ?

Be the first one to answer this question.