Wordpress using index.php over archive.php

November 9, 2014 698 views

Hi all,

I'm currently running into an issue on my Wordpress Multisite installation. I'm trying to create an archive page for my posts, which should normally use archive.php. However at this point Wordpress decides to use index.php, since archive.php can somehow not be found.

I'm thinking this is an issue in my apache/htaccess configuration, since I've also tried this using the default "TwentyFourteen" theme, which also doesn't seem to be working.

My .htaccess is using the default settings for a multisite configuration:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
RewriteRule ^(.*\.php)$ wp/$1 [L]
RewriteRule . index.php [L]

For my apache config file I'm using AllowOverride FileInfo configured on the /var/www folder. I've also tried AllowOverride All, but no success.

I'd really appreciate any help regarding this issue. Thanks in advance!

  • Lorenzo
Be the first one to answer this question.