Recognition

No awards yet.

Posts

3 Posts
  • Published Answer

    Nginx Cookieless Subdomain Not Working After Adding SSL

    I solved the SSL problems. Please view [this](https://www.digitalocean.com/community/questions/nginx-cookieless-subdomain-not-prope…
    Accepted Answer: I solved the SSL problems. Please view [this](https://www.digitalocean.com/community/questions/nginx-cookieless-subdomain-not-prope…
    By nhabbott
  • Published Question

    Nginx Cookieless Subdomain Not Properly Serving Files

    All of my static content is linked to https://static.mexicanraindeer.me, the problem is when the website sends get requests for the items. The response is HTTP/1.1 200 OK because the files are found, but all of them h...
    Accepted Answer: It seems like that's caused by the very last line (return 200 ...) A return in nginx will literally return the content that you specify in the config line, not the contents of the requested file. So what you are tell...
    1 By nhabbott Nginx LEMP Ubuntu
  • Published Question

    Nginx Cookieless Subdomain Not Working After Adding SSL

    I recently added Let's Encrypt SSL to my Nginx web server but it has broken my cookieless subdomain that serves static content. None of the static content is reached & the subdomain redirects to my main domain. The ma...
    Accepted Answer: I solved the SSL problems. Please view this (https://www.digitalocean.com/community/questions/nginx-cookieless-subdomain-not-properly-serving-files) question for my other "challenge".
    1 By nhabbott Let's Encrypt Nginx LEMP Ubuntu