Question

Accessing ownCloud via HTTP. We strongly suggest you configure your server to require using HTTPS instead.

Posted November 15, 2014 7.8k views

Hi Folks the community is awesome here! Ok so I set up owncloud on a droplet, however I get this when I login to my ownCloud
You are accessing ownCloud via HTTP. We strongly suggest you configure your server to require using HTTPS instead.

I was wondering if I could have some direction on how to set the server up to require https! Any help would be great thanks!

4 comments
  • See the mozilla guide. In general, to require (“force”) https, you need to redirect all http traffic to https with a 301 redirect, and send HSTS.

  • do you have an ssl cert set up? If not, you should start there… StartSSL has free certs and will work fine for OwnCloud

  • I set my droplet up without HTTPS … Duh!! Now I am going to follow these steps to adding it so I can avoid seeing the security warning message on my devices and ditto those I share files / links with!! Not pretty!

    Step1: Go to www.StartSSL.com and click on the top left image “Start SSL free class 1”.
    Step2: Complete your personal details
    Step3: Authenticate via email
    Step4: Wait for my details to be approved

    ..... waiting .....

  • That didn’t take long ....

    Ok Certificate generated, instructions followed and certificate backed up on my removable media drive.

    I presume (more research required at this point) that I need to install the certificate onto my droplet to enable HTTPS to work with Ownloud?

    I’ll update this later .....

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

my all client website have SSL certificate, and its really important for ownCloud, now server management are easy to us

Submit an Answer