Question

By accessing the site sgaimecbetim.com.br'm being redirected to the server ip 138.68.1.158, must remain the link being sgaimecbetim.com.br

By accessing the site sgaimecbetim.com.br’m being redirected to the server ip 138.68.1.158, must remain the link being sgaimecbetim.com.br.

Apparently dns not working


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Without more details it’ll be difficult to provide a 100% guaranteed solution for this problem but based on how often I see it, I have a guess.

First, this is not a DNS issue. DNS only makes sure that your computer finds out the IP address to send it’s request to. It would appear that DNS is working correctly as you are getting to the server. DNS cannot redirect a domain name to an IP address in your address bar, that has to be done by a web service.

Instead, this appears to be a default URL set in the software you are running your site on. This is a common issue for people using WordPress if they installed it using the IP address in the process rather than the name. WordPress will make sure that visitors are redirected to the configured domain name. In some cases this can make sure a www is present or not present in the domain or see that multiple domains pointed to one website all get redirected to the main name for that site.

You’ll need to update your WordPress configuration via the wp-admin panel and set your Site Address (URL) to your domain name under Settings->General.