Question

Cannot get domain.com/awstats to run ...

Posted September 3, 2013 15.5k views
Hi, DO droplet ubuntu Installed awstats fine but when trying to load the site URL in the browser then the page returns a 404 error. APC control panel loads fine as well as phpmyadmin will load. http://www.tuxreports.com/awstats/awstats.pl Followed this guide to install: https://help.ubuntu.com/community/AWStats Is the correct lines to add to the /etc/apache2/sites-available/domain.com file? Alias /awstatsclasses "/usr/share/awstats/lib/" Alias /awstatsicons/ "/usr/share/awstats/icon/" Alias /awstatscss "/usr/share/doc/awstats/examples/css" ScriptAlias /awstats/ /usr/lib/cgi-bin/ Options ExecCGI -MultiViews +SymLinksIfOwnerMatch Any ideas?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers
Redid the sites-available/domain file then restarted the apache2 service.

Error: Couldn't open config file "awstats.www.tuxreports.com.conf" nor "awstats.conf". Please read the documentation for directories where the configuration file should be located.

- Did you use the correct URL ?
Example: http://localhost/awstats/awstats.pl?config=mysite
Example: http://127.0.0.1/cgi-bin/awstats.pl?config=mysite
- Did you create your config file 'awstats.www.tuxreports.com.conf' ?
If not, you can run "awstats_configure.pl" from command line, or create it manually.

Check config file, permissions and AWStats documentation (in 'docs' directory)
Read the error:

- Did you create your config file 'awstats.www.tuxreports.com.conf' ? 

If not, you can run "awstats_configure.pl" from command line, or create it manually.

The article you linked above says how to properly create that config file. Did you follow that part?
Yes. Actually, I changed ownership for the files to www-data and now things work, including setting up the area for requiring a user ID and password (.htpasswd).

Hopefully this helps the next person struggling to get awstats working.
It most certainly did help! Can't believe I overlooked it, but the ownership was indeed my cause :(
Submit an Answer