Certbot error curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to

Posted April 13, 2021 3.1k views
Ubuntu 18.04

I’m doing certbot using snap and PPA, both fails miserably.
and some people on internet ask whether you can do a curl manually or not.
Then I tried to curl it, and it returns
error curl: (35) OpenSSL SSLconnect: SSLERROR_SYSCALL in connection to

Does anyone have the same problem ? FYI I’m using the lowest CPU on droplet

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers

Just created a snapshot and build a new droplet with the snapshot.
Certbot worked normally.
I think it’s because of other droplet (lowest droplet uses shared CPU).

Hi @noviceboy17,

In that regard, to your answer, can you confirm what Droplet are you using? What OS and additionally, did you try to run

apt update

Prior to trying to install certbot by any of the mentioned ways?

I’m not sure it’s related to the CPU and it might be something else.

Anyway, I’m glad to see everything is working accordingly.


  • Regardless the problem is resolved.
    I’m using Ubuntu 20.04, tried to rebuilt (same server) to 18.04.
    Problem still occured, I did everything including apt update.
    I also did curl , it works fine,
    but can’t curl
    Then I read in some forum that someone also having the same problem but he is on different scenario, his scenario is his other docker container connected to VPN.

    Because of that, I have a hunch what if I make another similar droplet using snapshot.
    And yes, certbot worked properly.