Question

ClamAV installation

Hi!

I install ClamAV on DO Ubuntu bionic VDS:

# apt install clamav clamav-daemon
# service clamav-daemon stop
# freshclam
# service clamav-daemon start

Freshclam updates database successfull:

Tue Mar  3 15:17:58 2020 -> --------------------------------------
Tue Mar  3 15:17:58 2020 -> ClamAV update process started at Tue Mar  3 15:17:58 2020
Tue Mar  3 15:17:58 2020 -> daily database available for update (local version: 25739, remote version: 25740)
Tue Mar  3 15:18:00 2020 -> Testing database: '/var/lib/clamav/tmp.1d0c5/clamav-972fa87623cc53abb781b5adc07e1c1d.tmp-daily.cld' ...
Tue Mar  3 15:18:05 2020 -> Database test passed.
Tue Mar  3 15:18:05 2020 -> daily.cld updated (version: 25740, sigs: 2204413, f-level: 63, builder: raynman)
Tue Mar  3 15:18:05 2020 -> main.cvd database is up to date (version: 59, sigs: 4564902, f-level: 60, builder: sigmgr)
Tue Mar  3 15:18:05 2020 -> bytecode.cvd database is up to date (version: 331, sigs: 94, f-level: 63, builder: anvilleg)
Tue Mar  3 15:18:05 2020 -> WARNING: Clamd was NOT notified: Can't connect to clamd through /var/run/clamav/clamd.ctl: No such file or directory

But ClamAV fails with message in log:

Tue Mar  3 15:45:06 2020 -> Reading databases from /var/lib/clamav
Tue Mar  3 15:45:06 2020 -> Not loading PUA signatures.
Tue Mar  3 15:45:06 2020 -> Bytecode: Security mode set to "TrustSigned".
Tue Mar  3 15:45:14 2020 -> ERROR: Malformed database
Tue Mar  3 15:45:14 2020 -> Closing the main socket.

Could it be that DO package repository and ClamAV DB are not compatible?

# apt-cache policy clamav
clamav:
  Installed: 0.102.2+dfsg-0ubuntu0.18.04.1
  Candidate: 0.102.2+dfsg-0ubuntu0.18.04.1
  Version table:
 *** 0.102.2+dfsg-0ubuntu0.18.04.1 500
        500 http://mirrors.digitalocean.com/ubuntu bionic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     0.99.4+addedllvm-0ubuntu1 500
        500 http://mirrors.digitalocean.com/ubuntu bionic/main amd64 Packages

Does somebody know how to fix problem? Thanks in advance.

Subscribe
Share

I have the same problem in debian 10 and because of that it does not respond postfix and smtp


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

SOLVED: addition of 2GB swap solved problem. ClamAV eats much memory:

# free -m
              total        used        free      shared  buff/cache   available
Mem:            985         888          67           0          29          12
Swap:          2047         294        1753