Hi
Quick question here
I built a wordpress website on digital ocean VPS
Address like http://104.131.49.218/
And I got name like myname.com
And follow the guide “how-to-set-up-a-host-name-with-digitalocean”
https://www.digitalocean.com/community/tutorials/how-to-set-up-a-host-name-with-digitalocean

Great, I connect the domain name with my site

But problem is
The original url with my page like this
http://104.131.49.218/contact/
And after update, the ideal result will be the old url will exchanged like
http://myname.com /contact/ this kind of url

Seems not work
Help needed
Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

This should be an easy fix:

  1. login to your wordpress dashboard
  2. left menu select “Settings” –> “General”
  3. then change both “WordPress Address (URL)” and “Site Address (URL)” from your IP to your domain name (don’t forget to also put http:// in front of your domain, or https:// if you have SSL) and hit “save changes”
  4. goto “Settings” –> “Permalinks” and click on “save changes”

Voila, you should be good to go :)

And don’t forget…
Your domain must resolv to your IP (DNS).

Great answer @sugarhill

It would be great if @julianlampert can elaborate on his answer!

Submit an Answer