curl: (6) Could not resolve host: bash. - Upgrade from the Legacy Metrics Agent to the Current Agent

Posted September 15, 2019 2.1k views
DigitalOceanUbuntu 18.04

When trying to upgrade the Legacy Metrics I keep getting the error:

curl: (6) Could not resolve host: bash

I’ve already tried suggestions found here:

Still no success.

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
3 answers


I assume you’re following this article:

You can also make sure that you haven’t copied some additional characters in the curl command itself:

curl -sSL | sudo bash

Also another thing to add, can you try pinging the source site/domain as well, just to see if it’s not a networking issue:


Looking forward to your reply.

facing same issue one of my do instance i have tried to ping showing me

ping: Temporary failure in name resolution

mine solves by disabling firewall temporarily