Question

Database server has gone away with BackupBuddy, but only on certain installs

  • Posted October 13, 2014

Hi, I’ve got two WordPress installs on a single droplet running Ubuntu 14.04 with nginx. In one install, BackupBuddy works, with the exception of two errors:

22:36:12	0.18sec	8.97MB	ERROR: mysqlbuddy: Error #43849374. Database went away from PHP while running from command line. The PHP <--> mysql connection likely timed out while we were doing other things. Error information & troubleshooting: http://ithemes.com/codex/page/BackupBuddy:_Error_Codes#43849374 
22:36:12	0.18sec	8.97MB	ERROR: Database Server reconnection failed.

Despite those errors, **BackupBuddy works on WP install #1 **

However, on WP install #2, it doesn’t work at all:

22:59:17	0.32sec	20.87MB	Database Server has gone away, attempting to reconnect.
22:59:17	0.32sec	20.87MB	Database Server reconnection failed.
22:59:17	0.32sec	20.87MB	ERROR: Database Server has gone away, unable to schedule next backup step. The backup cannot continue. This is most often caused by mysql running out of memory or timing out far too early. Please contact your host.

I’m not sure why BackupBuddy would work on one but not the other, since it’s on the same droplet connecting to the same database server.

I tried creating another Droplet, this time installing WP using EasyEngine. BackupBuddy doesn’t work there either. I have no idea what I did right in install #1.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have same problem with buddy press backup plugin. Its not work on php 5.5 + mysql 5.5 But work fine php 5.3 + mysql 5.1 or php 5.4 I think its related with new version php 5.5