Django Image: Gunicorn is not using a venv?

I am using the django image and I cannot figure out how to get gunicorn to use my venv… I cam accross this when I had trouble with importing something I had installed in my venv and IDK what to do…

I tried editing the gunicorn.conf file in /etc/init/gunicorn.conf to add

exec source /path/to/venv/bin/activate and that did not work…

Any ideas?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This question was answered by @deltaskelta:

it turns out I had quite a few issues that were all solved by looking at /var/log/upstart/gunicorn.log…

I needed to install gevent in my venv I then had some log files I needed to change the permissions of

View the original comment