Question

Docker suddenly shows errors, can't even rebuild old versions.

Getting some error that I’m not understanding:

[2022-01-11 16:45:55] error building image: error building stage: failed to execute command: resolving src: failed to get fileinfo for /kaniko/0/workspace/app/build/dependency/BOOT-INF/lib: lstat /kaniko/0/workspace/app/build/dependency/BOOT-INF/lib: no such file or directory

Haven’t touched the file at all, so it’s confusing why I’m getting this error.

I event rolled back to the last know working deployment and it still resulted in same error.

I tried manual redeploy that did not help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Had to use bootJar with newer SpringBoot version. Since the newer version creates multiple Jar files and *.jar finds only one.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This comment has been deleted