Email setup on CentOS 6.5 x32 Webuzo?

September 27, 2014 6.5k views

Hello.This is my first post here and i see this a very helpful community.However i can't find any instructions on how to setup an email server on CentOS 6.5 x32. I mean i have installed webuzo control panel but neither php mail or SMTP or working on my Webuzo panel.
So here i'm confused. Do i need to install/configure an email server via Putty or the Webuzo can do that via some settings? In any case any help would be appreciated.Thanks a lot.

2 Answers

You can install Exim and Dovecot by a click from the Webuzo Enduser Panel
Guide : http://www.webuzo.com/wiki/Install_System_Apps

By default sendmail acts as the smtp service and should work fine.
Hope this helps :)

  • By default sendmail acts as the smtp service and should work fine.
    Hope this helps :)

    Right now,which by default,is not working at all..i will try your recommended plugins to see if they work. But are you sure that i do not need to install first some kind of email settings via console/putty?

  • Yes Sir, the default should work well for basic emails send/receive
    Once you install Dovecot and Exim , you will be able to create email accounts for your domains
    E.g support@example.com

  • Don't get me wrong but you are still not clearly enough...what do you mean by default? You mean once webuzo is installed the e-mail function should work? ( as i have installed but emails are not working at all ) ...or by default like, once i will install what you said ,it will work?
    Thanks a lot once more for your help.

    PS: Your first comment wiki link has no content: "There is currently no text in this page."

  • Sir you can install Exim and Dovecot from the Webuzo Enduser Panel >> Apps >> Utilities >> Dovecot

    Valid - Link : [http://www.webuzo.com/wiki/Install_System_Apps](http://)
    Seems {underscore} is not allowed in links

    This should resolve your issues with emails.
    You can always refer the Webuzo Wiki. It is loaded with plenty of information.

  • Ok.Did as you said but still is not working..I have restarted my droplet but i still can't receive or send emails on created email account.
    When i login via SquireMail and compose a message and click send i receive the following message:

    Message not sent. Server replied:
    Requested action not taken: mailbox unavailable
    550 Sender verify failed

    Also by typing in my console exim -bt info@mydomain.net ,i receive this:

    postmaster@ is undeliverable: mail domain "" is syntactically invalid

    I have installed my droplet twice,thinking that i might did some wrong steps but still the same error.

  • Seems the emails to "info" are forwarded to "postmaster" causing the trouble.

    Quick solution is to edit the file /etc/aliases and comment the lines which hold the word "info"

    For example

    info : postmaster


    #info : postmaster

    Restart your services from the terminal for once.

    service dovecot restart
    service exim restart

    Hope it helps :)

  • It worked..but now i can receive but can't send. The emails i send ,they never get delivered..and no errors after i click send. Why does it have to be so complicated with the email function? :(

    Is it possible that the Mailing Method be the problem? How about switching to SMTP..what info i must enter in these fields?

    SMTP Server

    SMTP Port

    SMTP Username

    SMTP Password

    And for the SMTP Username and password should i just type a random info or it must be the username and password i have created my Webuzo install?

  • Is your hostname a Fully Qualified Domain Name ? If No, set it to your Domain Name

    SMTP Server : domain.com

    SMTP Port : 25

    SMTP Username : info@domain.com

    SMTP Password : *yourpassword*

    Hope this helps :)

  • No luck..The same issue..i can receive but i can't send. Webuzo is useless for me without the email function. Any other suggestion please? Thank you.

  • You can open a Support Ticket with Webuzo, we will debug the issue on your server and resolve the same.

  • I'm using the free version ..do you offer support for the free version also?

  • Sir I shall debug and resolve your issue. Do not worry :)

  • :) Ticket created.

  • I created a test account on your server and sent emails to-n-fro
    Works well !!!

  • I tried on yahoo based emails ..is not working. On gmail is working.

Have another answer? Share your knowledge.