Question

Enable IPv6 on existing Ubuntu Droplet

I followed this tutorial to enable IPv6 on my existing Ubuntu 18.04.3 LTS Droplet. My server doesn’t have anything in /etc/netplan, so I followed instructions for Ubuntu 16.04 and change /etc/network/interfaces. I add suggested stuff (changed with IPv6 addresses I got on DigitalOcean dashboard while enabling IPv6). After the service restart, I got:

Dec 16 06:00:41 localhost systemd[1]: Stopping Raise network interfaces...
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: deleted default route via 46.101.128.1
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: deleted IP address 46.101.132.77/18
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: deleting route to 46.101.128.0/18
Dec 16 06:00:41 localhost ifdown[1457]: RTNETLINK answers: No such process
Dec 16 06:00:41 localhost ifdown[1457]: RTNETLINK answers: Cannot assign requested address
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: arp if_readrawpacket: Network is down
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: carrier lost
Dec 16 06:00:41 localhost systemd[1]: Stopped Raise network interfaces.
Dec 16 06:00:41 localhost systemd[1]: Starting Raise network interfaces...
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: carrier acquired
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: IAID 86:e5:62:01
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: adding address fe80::88e6:3b61:12cd:fe3d
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: using static address 46.101.132.77/18
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: adding route to 46.101.128.0/18
Dec 16 06:00:41 localhost dhcpcd[1073]: eth0: adding default route via 46.101.128.1
Dec 16 06:00:41 localhost ifup[1544]: RTNETLINK answers: File exists
Dec 16 06:00:41 localhost ifup[1544]: Failed to bring up eth0.
Dec 16 06:00:41 localhost systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
Dec 16 06:00:41 localhost systemd[1]: networking.service: Failed with result 'exit-code'.
Dec 16 06:00:41 localhost systemd[1]: Failed to start Raise network interfaces.
Dec 16 06:00:42 localhost dhcpcd[1073]: eth0: soliciting an IPv6 router
Dec 16 06:00:55 localhost dhcpcd[1073]: eth0: no IPv6 Routers available

  1. Any idea what can be wrong?
  2. Why my server still uses the old way of networking (and not netplan)? I didn’t remember, maybe it was upgraded?

Regards.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @kacnje

Yes you need to follow this tutorial.

https://www.digitalocean.com/docs/networking/ipv6/how-to/enable/

Let us know if you have any questions.

Regards, Alex