Error while installing packages.

Posted January 24, 2013 11.5k views
cryptsetup: WARNING: failed to detect canonical device of /dev/xvda cryptsetup: WARNING: could not determine root device from /etc/fstab I am getting those two errors, any idea?
1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
13 answers
Or is it safe to ignore those?
Can you paste what command you ran for the install when you got these errors?
Yes, I ran: "apt-get upgrade" and then I upgraded packages.
Best to open a support ticket with the full output so we can help troubleshoot this with you.
I've been seeing this same issue for quite some time. I just did another `apt-get upgrade` and it happened. Could you please publicize the solution? Googling around doesn't give much insight (though I actually found this thread from Google).
This is an issue related to the kernel and modules being mismatched during the system upgrade and is caused by the fact that the kernel is being loaded through the hypervisor and not your local virtual machine.

The fix to this is to allow customers to manage their own kernels in which case they would be synced to your system so running a system upgrade would not cause these errors.

We are currently about 3-4 weeks away from releasing that so hopefully this issue will be resolved soon.
@raiyu - Could we get an update on the status of a resolution please?

I ran across this issue earlier today.
@rvg: Update your droplet and /then/ update your kernel from the Settings tab in your droplet's page. It should fix the kernel modules issue.
It did indeed - Thanks Kamal
Previous 1 2 Next